Community for yuuvis® RAD

0 votes
by (2k points)
edited by

Dear OS-Engineers,

after we have updated our https certificate on our enaio windows maschines, we can't use the custom-clients eopx proxy.
We always get the error

[HPM] GET /auth/info -> https://zpue-dev01.test-server.ag
[HPM] Error occurred while trying to proxy request /auth/info from localhost:4200 to https://zpue-dev01.test-server.ag (EPROTO) (https://nodejs.org/api/errors.html#errors_common_system_errors)
[HPM] POST /login -> https://zpue-dev01.test-server.ag
[HPM] Error occurred while trying to proxy request /login from localhost:4200 to https://zpue-dev01.test-server.ag (EPROTO) (https://nodejs.org/api/errors.html#errors_common_system_errors)

We also tried to use angulars --ssl-key and --ssl-cert parameters with the same certificate, we use on our maschines. But that didn't work as well.

"start": "ng serve --ssl --ssl-cert ssl/dev01.crt --ssl-key ssl/dev01.key --proxy-config src/proxyDEV01.config.json --open",

It seems the eopx doesn't even receive any requests:

Starting up proxy server on http://127.0.0.1:4300
Target URL is https://zpue-dev01.test-server.ag
Hit CTRL-C to stop proxy

We can start the custom-client, but we can't login. We receive 500 Internal Server Errors.
See screenshot: https://prnt.sc/tdx9qn

Is there a missing necessary step to configure eopx or is there a requirement for the certificate in order to work properly?

1 Answer

0 votes
by (12.9k points)

Hi Dennis,

seems that your certificate is not trusted as given on the system you are working on.

Infos about the situation: https://www.ssl2buy.com/wiki/how-to-fix-err_cert_common_name_invalid-in-chrome

You wrote that you have change the certificate. Was everything working before?

Best Regard,
Martin

Related questions

+1 vote
2 answers
0 votes
2 answers
asked Mar 29, 2019 by dcieplik (820 points)
0 votes
6 answers
0 votes
2 answers
asked Aug 3, 2018 by dennisschmidt (2k points)
...